[Ffmpeg-devel] h264/rtp transport (RFC 3984)

Michael Niedermayer michaelni
Wed Oct 4 22:14:15 CEST 2006


On Wed, Oct 04, 2006 at 02:40:33PM -0500, Ryan Martell wrote:
> Okay, so I'm really, really close to implementing h264 over rtp (per  
> RFC 3984).
> I am getting video, but there is lots of grey.  I am getting lots of  
> "Concealing 150 MV errors, .." messages.
> I have looked over my byte manipulations all morning, and I am pretty  
> sure that I am decoding the stream correctly, and creating the AvCC  
> stuff from the SDP announce (I have verified that my code produces  
> the same avc block as the file that is sourced from the server).  I  
> am prepending a 4 byte NAL packet length to the start of every  
> packet, so it goes through the AVC loop just fine.  Byteswapping all  
> looks good.
> So... I'm thinking that the problem has to do with my timestamps and  
> sequence numbers.  I'm going to start looking into this right now,  
> but if anyone knows whether that would account for lots of grey  
> (including grey on the bottom half of the full frames?), I would  
> appreciate knowing that I am on the right track.

this sounds a little like you feed incomplete frames into the decoders
this is not supported concatenate all packets for one frame and then 
give it to the decoder, you can also use a AVParser to do that for you ...

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

In the past you could go to a library and read, borrow or copy any book
Today you'd get arrested for mere telling someone where the library is

More information about the ffmpeg-devel mailing list