[Ffmpeg-devel] [PATCH] Don't use --as-needed for every operating system

Luca Barbato lu_zero
Mon Oct 16 19:47:18 CEST 2006

Diego 'Flameeyes' Petten? wrote:
> Currently gcc (that is the first user of it) consider it working only for 
> Linux, because on at least FreeBSD and DragonFly it's not usable (by design).
> The reason is that -pthread for libraries is a no-op, while on final 
> executables it brings in -lpthread, even if it does not resolve local 
> unresolved symbols, to link the libraries using pthreads themselves. 
> With --as-needed, the final link to libpthread is then discarded, resulting 
> in unusable libav* libraries.

Which other os have similar behaviour?



Luca Barbato

Gentoo/linux Gentoo/PPC

More information about the ffmpeg-devel mailing list