[Ffmpeg-devel] [PATCH] Don't use --as-needed for every operating system

Diego 'Flameeyes' Pettenò flameeyes
Mon Oct 16 20:08:01 CEST 2006

On Monday 16 October 2006 19:47, Luca Barbato wrote:
> Which other os have similar behaviour?
BSD-based seem to be the main ones; I'm not sure about Solaris, as I don't 
have access to one myself.
Also, --as-needed only makes sense for ELF targets, as far as I can see, and 
this rules out its usefulness for PE (Windows) and Mach-O (Mac OSX).

Diego "Flameeyes" Petten? - http://farragut.flameeyes.is-a-geek.org/
Gentoo/Alt lead, Gentoo/FreeBSD, Video, Sound, ALSA, PAM, KDE, CJK, Ruby ...

More information about the ffmpeg-devel mailing list