[Ffmpeg-devel] Re: new grab interface breaks bktr grabing

Ramiro Ribeiro Polla ramiro
Wed Apr 4 20:46:04 CEST 2007

Nikns Siankin wrote:
> On Tue, Apr 03, 2007 at 02:56:09PM -0700, Piero Bugoni wrote:
>> --- Nikns Siankin <nikns at secure.lv> wrote:
>>> First I tried:
>>> ffmpeg -y -f bktr -i /dev/bktr0 -an -vcodec wmv2
>>> -tvstd pal /root/test.wmv
>>> /dev/bktr0: Error while opening file
>>> Then I remembered that even with old ffmpeg there
>>> was such error if no frame
>>> size specified, but running:
>>> ffmpeg -y -f bktr -i /dev/bktr0 -an -vcodec wmv2
>>> -tvstd pal -s cif /root/test.wmv
>>> didn't help either.
>>> Hovewer, specifying "-s" in front of args finnaly
>>> started capturing:
>>> ffmpeg -y -s cif -f bktr -i /dev/bktr0 -an -vcodec
>>> wmv2 -tvstd pal /root/test.wmv
>> [...]
>>> Anyone have success grabing from bktr with new grab
>>> interface?
>> Thanks for this. I have been using ffmpeg for a while
>> on Slackware Linux, but just set it up today on
>> FreeBSD 6.2. I referred back to your info to get
>> grabbing to work. (The command line is different from
>> Linux. I might have fucked around for hours trying to
>> get it to work without this info.)
>> The kernel was rebuilt to remove all unnecessary
>> drivers, and bktr built in statically. (The box was an
>> old  450MHz PIII with 128M RAM, so it was pared down
>> to minimum, just to be sure. The bktr driver
>> complained about unable to allocate memory when loaded
>> with kldload, but seemed to load ok when loaded at
>> boot with  loader.conf. The card was a LW-104 --aka
>> Pico2000 ebay special).
>> I used SVN-r8618, downloaded today.
>> This command worked:
>> ./ffmpeg -y -s cif -f bktr -i /dev/bktr0 -an  -tvstd
>> ntsc test.mpg
>> (Although I got this repeating error message that I
>> think has to do with the bktr driver):
>> SLEPT NO signals - xxxx microseconds late
>> Generally speaking, the video looked OK.
>> I do not know if this is an issue for ffmpeg-user, or
>> not, so I mention it here.
> So you say video played smoothly?
> Then, perhaps there are another openbsd
> specific issues with code that went in from
> january till april.
> Want to try on openbsd? Just pick 4.0 install,
> bktr is in by default.
Did you read [1]?
Please try the -isync option and report back. Set the verbose options to 
see how many dupes/drops there are, like:
./ffmpeg -v 9 -isync -y -s cif -f bktr -i /dev/bktr0 -an -tvstd ntsc 

Try that with and without -isync.

Ramiro Polla

[1] http://article.gmane.org/gmane.comp.video.ffmpeg.devel/47852

More information about the ffmpeg-devel mailing list