[FFmpeg-devel] 16:9 DV AVI not detected

Michael Niedermayer michaelni
Mon Dec 31 20:21:54 CET 2007

On Sun, Dec 30, 2007 at 09:13:33PM -0800, Roman Shaposhnik wrote:
> On Dec 30, 2007, at 7:23 AM, j at v2v.cc wrote:
> > 16:9 ntsc avi dv files exported with Adobe Premiere,
> > the aspect ratio is not properly detected. it is always
> > set to 1:1. what would be the right place to fix this?
> >
> > the only place i could find that sets sample_aspect_ratio
> > is dv_extract_video_info in libavformat/dv.c
> > dont see this used for avi files...
>    I bet the problem is -- AVI container not signaling the
> aspect ratio properly. It's been a problem for broken
> application all along. It's a pity if Adobe Premiere
> happens to be among a broken bunch.

avi has no field for aspect ratios (or at least not last time i looked
at the specs ...)

>     The only possible workaround that I know of is to
> do what is done for AVI type 1 DV, but it'll be more
> trouble than it is worth. IMHO.

if the dv decoder knows the aspect ratio, it should just set
AVCodecContext.sample_aspect_ratio (no i dont know if this would fix the

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Opposition brings concord. Out of discord comes the fairest harmony.
-- Heraclitus
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20071231/fc460133/attachment.pgp>

More information about the ffmpeg-devel mailing list