[FFmpeg-devel] 16:9 DV AVI not detected

Roman Shaposhnik rvs
Mon Dec 31 21:57:41 CET 2007

On Dec 31, 2007, at 11:21 AM, Michael Niedermayer wrote:

> On Sun, Dec 30, 2007 at 09:13:33PM -0800, Roman Shaposhnik wrote:
>> On Dec 30, 2007, at 7:23 AM, j at v2v.cc wrote:
>>> 16:9 ntsc avi dv files exported with Adobe Premiere,
>>> the aspect ratio is not properly detected. it is always
>>> set to 1:1. what would be the right place to fix this?
>>> the only place i could find that sets sample_aspect_ratio
>>> is dv_extract_video_info in libavformat/dv.c
>>> dont see this used for avi files...
>>    I bet the problem is -- AVI container not signaling the
>> aspect ratio properly. It's been a problem for broken
>> application all along. It's a pity if Adobe Premiere
>> happens to be among a broken bunch.
> avi has no field for aspect ratios (or at least not last time i looked
> at the specs ...)

   You know what -- you're right. I guess I was thinking about .mov
(or may be not thinking at all -- you know, Russian New Year  and
stuff ;-)).

>>     The only possible workaround that I know of is to
>> do what is done for AVI type 1 DV, but it'll be more
>> trouble than it is worth. IMHO.
> if the dv decoder knows the aspect ratio,

   It doesn't right now. That logic is in  the DV demuxer. btw, would
you agree that things like SAR/DAR signaling are actually part
of the container, not codec info?

> it should just set
> AVCodecContext.sample_aspect_ratio (no i dont know if this would  
> fix the
> problem)

    I guess that would make sense. But see my previous question.


P.S. Happy New Year!

More information about the ffmpeg-devel mailing list