[FFmpeg-devel] [PATCH] Move the video size and rate abbreviations system from libavformat to libavcodec

Benoit Fouet benoit.fouet
Tue Jun 12 09:35:58 CEST 2007


Michael Niedermayer wrote:
> Hi
>
> On Mon, Jun 11, 2007 at 02:35:47PM +0200, Stefano Sabatini wrote:
>   
>> On date Monday 2007-06-11 14:11:36 +0200, Benoit Fouet encoded:
>>     
>>> Hi,
>>>
>>> Stefano Sabatini wrote:
>>>       
>>>> Index: libavformat/utils.c
>>>> ===================================================================
>>>> --- libavformat/utils.c	(revision 9235)
>>>> +++ libavformat/utils.c	(working copy)
>>>> -int parse_frame_rate(int *frame_rate, int *frame_rate_base, const char *arg)
>>>> +int parse_frame_rate(int *frame_rate_num, int *frame_rate_den, const char *arg)
>>>>   
>>>>         
>>> why do you rename those parameters ?
>>>       
>> First solution:
>> int parse_frame_rate(int *frame_rate, int *frame_rate_base, const char *arg)
>> {
>>     AVRational frame_rate_q;
>>     int ret = av_parse_video_frame_rate(&frame_rate_q, arg);
>>     *frame_rate= frame_rate_q.num;
>>     *frame_rate_base= frame_rate_q.den;
>>     return ret;
>> }
>>
>> Second one:
>> int parse_frame_rate(int *frame_rate_num, int *frame_rate_den, const char *arg)
>> {
>>     AVRational frame_rate;
>>     int ret = av_parse_video_frame_rate(&frame_rate, arg);
>>     *frame_rate_num= frame_rate.num;
>>     *frame_rate_den= frame_rate.den;
>>     return ret;
>> }
>>
>> The second one looks better to me, but that doesn't really matter, and
>> yep, it's a cosmetic change, it seems I can't resist without making them ;-),
>> so please choose which you prefer (first one attached).
>>     
>
> i think iam fine with the patch
>
>   

which one ? :)

Ben
-- 
Purple Labs S.A.
www.purplelabs.com




More information about the ffmpeg-devel mailing list