[Ffmpeg-devel] Naming conventions
Tue Mar 6 14:04:36 CET 2007
On Tue, Mar 06, 2007 at 01:37:00PM +0100, Baptiste Coudurier wrote:
> > and what about
> > avpicture_get_size would that be av_picture_get_size or av_picture_size_get ?
> av_picture_get_size, av_picture_fill, av_picture_pad ...
why get_size? and not size_get? you mix type_action with action_type in a
> > i think giving functions natural english names is better
> > av_get_size_of_picture maybe?
> Reasonnably shortest, av_picture_get_size, av_pict_g_sz is not reasonable.
> > or lets try av_set_pts_info()
> > should that become av_pts_info_set() or av_info_pts_set() or
> > maybe av_stream_timebase_set() ?
> av_stream_set_timebase yes.
same you mix type_action with action_type in a single name
either use natural language or use a strict convention but what you
do is mixing both ...
iam VERY strongly against this style of naming functions its IMO the
worst possible choice
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
If you really think that XML is the answer, then you definitly missunderstood
the question -- Attila Kinali
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the ffmpeg-devel