[Ffmpeg-devel] Naming conventions
Tue Mar 6 14:18:17 CET 2007
Michael Niedermayer wrote:
> On Tue, Mar 06, 2007 at 01:37:00PM +0100, Baptiste Coudurier wrote:
>>> and what about
>>> avpicture_get_size would that be av_picture_get_size or av_picture_size_get ?
>> av_picture_get_size, av_picture_fill, av_picture_pad ...
> why get_size? and not size_get? you mix type_action with action_type in a
> single name
I don't mix them, type: av_picture, action: get_size
>>> i think giving functions natural english names is better
>>> av_get_size_of_picture maybe?
>> Reasonnably shortest, av_picture_get_size, av_pict_g_sz is not reasonable.
>>> or lets try av_set_pts_info()
>>> should that become av_pts_info_set() or av_info_pts_set() or
>>> maybe av_stream_timebase_set() ?
>> av_stream_set_timebase yes.
> same you mix type_action with action_type in a single name
no, type: av_stream, action: set_timebase.
> either use natural language or use a strict convention but what you
> do is mixing both ...
Baptiste COUDURIER GnuPG Key Id: 0x5C1ABAAA
SMARTJOG S.A. http://www.smartjog.com
Key fingerprint 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
Phone: +33 1 49966312
More information about the ffmpeg-devel