[Ffmpeg-devel] Naming conventions
Tue Mar 6 14:43:09 CET 2007
On Tue, Mar 06, 2007 at 02:32:49PM +0100, Michael Niedermayer wrote:
> On Tue, Mar 06, 2007 at 02:18:17PM +0100, Baptiste Coudurier wrote:
> > Michael Niedermayer wrote:
> > > Hi
> > >
> > > On Tue, Mar 06, 2007 at 01:37:00PM +0100, Baptiste Coudurier wrote:
> > > [...]
> > >>> and what about
> > >>>
> > >>> avpicture_get_size would that be av_picture_get_size or av_picture_size_get ?
> > >> av_picture_get_size, av_picture_fill, av_picture_pad ...
> > >
> > > why get_size? and not size_get? you mix type_action with action_type in a
> > > single name
> > I don't mix them, type: av_picture, action: get_size
> why not type: av_picture_size action: get?
> the question maters for a naming convention ...
> also what would av_new_stream() be called then?
> av_format_context_new_stream() ? this is ugly
> and av_index_search_timestamp() would end with
> av_stream_index_timestamp_search() or av_stream_index_search_timestamp() or
> all depending on where the type ends not to mention the silly long
> and the action is logically here on the index not on AVStream but
> AVStream is the type you must pass to the function!
> the whole naming convention talk reminds me of M$ hungarian notation
> = "useless and silly"
my _current_ suggestion for a nameing convention would be
1. av_ prefix on all new public global symbols
2. ff_ prefix on all new private global symbols
3. remaining name is the decission of the maintainer of the specific part
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Good people do not need laws to tell them to act responsibly, while bad
people will find a way around the laws. -- Plato
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the ffmpeg-devel