[FFmpeg-devel] [PATCH] add alloc_put_byte function

Aurelien Jacobs aurel
Sun Feb 3 23:07:24 CET 2008

Reimar Doeffinger wrote:

> Hello,
> On Sun, Feb 03, 2008 at 08:00:54PM +0100, Baptiste Coudurier wrote:
> > 3) Aurel emitted doubts about API breaking, and I won't ignore
> > other's opinions just because I want the change.
> It seems he did not have all the details though. Though in the mean
> time the version number was changed, so the argument does not hold.


> > Now I consider, like Aurel, that this change will actually break
> > API, so Im reconsidering the change, because it is only justified
> > for the sake of naming consistency and will cause trouble for
> > people already using it.

I still consider it's breaking API.
But I don't care at all about breaking API, as long as major version
is increased at the same time.

> So how about #ifdef ing it for a major version number change?
> If you think the naming is inconsistent, just leaving it as it is, is
> no good either. Though I do not know if you consider it that
> inconsistent.

I think the naming is inconsistent, and I agree it need to be changed.
IMO, we should just increase major at the same time and be done with it.
But if you prefer #ifdef ing it for next major version bump, I'm fine
with it too.


More information about the ffmpeg-devel mailing list