[FFmpeg-devel] [PATCH] add alloc_put_byte function
Sun Feb 3 20:24:32 CET 2008
On Sun, Feb 03, 2008 at 08:00:54PM +0100, Baptiste Coudurier wrote:
> This change is only to keep functions names consistent within libavformat.
And how does letting inconsistent function names "ripe" help anyone? (though
maybe the issue here is that it already is quite "ripe").
I do not consider one a lot more consistent than the other, but I happily
go with what others say.
> 1) You applied it without considering my opinion just because you didn't
> want to delay another patch. this is clearly NOT acceptable.
I certainly did consider it. I explained why I chose the name, since I did
not get a reply either way I went ahead with what I had. I admit that only
just over 24 hours was not a long time to wait for a reply though, sorry.
I just did not really want to wait to commit until mid-January and
half-forgetting about the patch nor did I want to commit something right
on the day before going on holidays.
> 2) You did extend API without bumping minor.
Which was intentional, I would have fixed that shortly later if there
was not that pending naming issue.
I did not expect it to stay like that for over a month (unfortunately
I just forgot about this).
> 3) Aurel emitted doubts about API breaking, and I won't ignore other's
> opinions just because I want the change.
It seems he did not have all the details though. Though in the mean time
the version number was changed, so the argument does not hold.
> Now I consider, like Aurel, that this change will actually break API, so
> Im reconsidering the change, because it is only justified for the sake
> of naming consistency and will cause trouble for people already using it.
So how about #ifdef ing it for a major version number change?
If you think the naming is inconsistent, just leaving it as it is, is no good
either. Though I do not know if you consider it that inconsistent.
More information about the ffmpeg-devel