[FFmpeg-devel] build problems on OpenBSD

Måns Rullgård mans
Wed May 28 16:49:22 CEST 2008

Jacob Meuser <jakemsr at sdf.lonestar.org> writes:

> hi
> I'm having some problems building recent ffmpeg svn versions.  in fact,
> I can't even get started :(
> here's what happens with a clean checkout:
> acer:~/tmp/ffmpeg-svn-20080527% ./configure
> nm: unknown option -- P
> usage: nm [-aCegnoprsuVw] [file ...]

Your nm is not POSIX compatible.  Get a better one.

> od: unknown option -- A
> od: od(1) has been deprecated for hexdump(1).
> usage: od [-aBbcDdeFfHhIiLlOovXx] [-j offset] [-N length] [-t type_string]
>         [[+]offset[.][Bb]] [file ...]

POSIX mandates an "od" tool.  Get a compliant one.

> [normal display of what configure decides will be built]
> Creating config.mak and config.h...
> acer:~/tmp/ffmpeg-svn-20080527% gmake
> gmake: *** virtual memory exhausted.  Stop.
> acer:~/tmp/ffmpeg-svn-20080527% 

You need GNU make 3.81.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list