[FFmpeg-devel] [PATCH] Split bitstream.h

Stefano Sabatini stefano.sabatini-lala
Sat Apr 11 23:25:26 CEST 2009

On date Saturday 2009-04-11 18:20:31 -0300, Ramiro Polla encoded:
> On Sat, Apr 11, 2009 at 3:27 PM, Stefano Sabatini
> <stefano.sabatini-lala at poste.it> wrote:
> > Hi, as suggested by Michael here it is a patch which splits
> > bitstream.h and creates a new bitstream_writer.h file.
> >
> > Maybe it would make sense to rename bitstream.h to bitstream_reader.h,
> > since it now only contains the reader stuff.
> Minor bikeshed: why not put_bits.h and get_bits.h?

No opinion on this, also maybe they're better than
bitstream_{writer,reader}.h since they're shorter.

If that's OK then the split may happen like this:
svn cp bitstream.h put_bits.h
svn mv bitstream.h get_bits.h


FFmpeg = Forgiving Free Mournful Plastic Entertaining Gadget

More information about the ffmpeg-devel mailing list