[FFmpeg-devel] ALAC encoder is not bitperfect

Jai Menon jmenon86
Mon Apr 13 20:06:40 CEST 2009

On 4/13/09, Brent Huisman <brenthuisman at gmail.com> wrote:
> Hey Jai,
>  I've used several different builds, including the new ffmpeg 0.5. Any
>  and all versions I tried exhibit this behaviour. Also any and all
>  source wave files I use have this. Have you tried bitcomparing
>  yourself?

Yes, and the output is bitexact as far as I have seen. Please specify
what exactly you are using to bitcompare. If its foobar2k bitcompare,
then sadly thats a bug in fb2k's mp4 demuxer and should be reported to
them. I think Justin posted something in this regard to HydrogenAudio.
FFmpeg'a alac encoder writes out the no. of samples in every frame
correctly which fb2k discards and instead pads the frame with zeroes.
Try checking the bitexactness using itunes or ffalac.

> I've read more reports of these consistent mismatches, so
>  I'm pretty sure you'll experience them as well.

I believe this is specific to foobar2k. Could you try with itunes instead?

>  Thanks,
>  Brent



More information about the ffmpeg-devel mailing list