[FFmpeg-devel] Build problem

David DeHaven dave
Wed Feb 4 18:10:33 CET 2009

>>> Art: What version of yasm did you install? x264 requires a very  
>>> recent
>>> version (0.7.x i think) and the asm code has been written by x264
>>> devs. Just install the latest version from the yasm site.
> I did.  I installed yasm and it fails.  I also tried yasm
> 0.7.1 to no avail.

SVN r2161 has the mach-o alignment fix in it. Current svn revision is  
nasm 2.06rc2 and later have the fix, but I think macho64 support is  
half-baked at the moment since there's no Mach-O maintainer.

But that won't fix the problem when building a 64 bit shared lib.


More information about the ffmpeg-devel mailing list