[FFmpeg-devel] xvmc_render.h ---> xvmc.h

Diego Biurrun diego
Sun Feb 8 04:31:44 CET 2009

On Sun, Feb 08, 2009 at 01:15:54AM +0200, Ivan Kalvachev wrote:
> On 2/7/09, Diego Biurrun <diego at biurrun.de> wrote:
> > I suggest renaming xvmc_render.h ---> xvmc.h, similar to vdpau.h.
> > There is no good reason for the _render suffix.
> I'm against using generic names for external stuff.
> If you want to rename something rename vdpau.

vdpau was explicitly renamed from vdpau_render.h to vdpau.h.
The same should be done for xvmc_render.h.

Generic names are not a problem anymore, since we require that
#includes should use libavcodec/ as prefix.


More information about the ffmpeg-devel mailing list