[FFmpeg-devel] [PATCH] --enable-libx264 and --enable-libxvid depend on --enable-pthread

Robert Swain robert.swain
Sat Feb 28 01:42:23 CET 2009

2009/2/28 Aurelien Jacobs <aurel at gnuage.org>:
> M?ns Rullg?rd wrote:
>> Brad <brad at comstyle.com> writes:
>> > On Friday 27 February 2009 18:43:58 M?ns Rullg?rd wrote:
>> >> pkg-config fails miserably if you are cross-compiling, something
>> >> FFmpeg must support.
> I've already cross-compiled numbers of packages, some of them using
> pkg-config, so it doesn't seem to be as broken as you pretend.

This is slightly off topic but, as I recall, the videolan peoples and
others would appreciate 'working' .pc files for FFmpeg. You sound like
you're very familiar with pkg-config and know what broken is with
regard to it.

Do you have time to make some good and working .pc for FFmpeg if they
are indeed broken? And, do you have time to fix the x264 .pc? I'm sure
all of this would be appreciated by many except M?ns. When we have
this, if M?ns can think of a better way to achieve its functionality,
it sounds like he will implement it/fix whatever issues there are in
FFmpeg. If he can't then I don't see why we shouldn't use pkg-config.

Trolling back and forth is not productive, not that all messages in
this thread have been trolling.


More information about the ffmpeg-devel mailing list