[FFmpeg-devel] [PATCH] --enable-libx264 and --enable-libxvid depend on --enable-pthread

Aurelien Jacobs aurel
Sat Feb 28 02:40:23 CET 2009

Robert Swain wrote:

> 2009/2/28 Aurelien Jacobs <aurel at gnuage.org>:
> > M?ns Rullg?rd wrote:
> >
> >> Brad <brad at comstyle.com> writes:
> >>
> >> > On Friday 27 February 2009 18:43:58 M?ns Rullg?rd wrote:
> >> >> pkg-config fails miserably if you are cross-compiling, something
> >> >> FFmpeg must support.
> >
> > I've already cross-compiled numbers of packages, some of them using
> > pkg-config, so it doesn't seem to be as broken as you pretend.
> This is slightly off topic but, as I recall, the videolan peoples and
> others would appreciate 'working' .pc files for FFmpeg. You sound like
> you're very familiar with pkg-config and know what broken is with
> regard to it.

Not as much as you may think.

> Do you have time to make some good and working .pc for FFmpeg if they
> are indeed broken?

FFmpeg's .pc files are (mostly?) correct AFAIK. But if someone
reports problem about them, I will have a look at it.

> And, do you have time to fix the x264 .pc?

I am not familiar at all with x264 and it's build system, but I
will probably give it a try.


More information about the ffmpeg-devel mailing list