[FFmpeg-devel] [PATCH] --enable-libx264 and --enable-libxvid depend on --enable-pthread

Måns Rullgård mans
Sat Feb 28 01:53:08 CET 2009

Jason Garrett-Glaser <darkshikari at gmail.com> writes:

> On that note, anyone have any ideas about how to fix ffmpeg's current
> problem with x264?  If x264.h is current but the x264 library itself
> is not, ffmpeg will think the version check succeeded and link itself
> to an ancient x264, resulting in random weird segfaults and other such
> things.  I have seen half a dozen people already with this problem in
> #ffmpeg.

How would we detect this situation?  If the header is present, and the
library can be linked against, we must assume that the installation is
correct.  Users with broken installations can blame themselves.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list