[FFmpeg-devel] [PATCH]Possible configure support for VDPAU

Måns Rullgård mans
Tue Jan 6 10:29:54 CET 2009

Gwenole Beauchesne <gbeauchesne at splitted-desktop.com> writes:

> Hi,
> On Mon, 5 Jan 2009, Diego Biurrun wrote:
>> I wonder if vdpau_render.h is a good name for the header.
> What about avaccel_vdpau.h? Or some other meaningful prefix? hwaccel_, 
> etc.

It already has a prefix: libavcodec/

> I would like to avoid plain header name provided by the vendor, even if 
> it's installed under another directory. i.e. avoid plain vdpau.h, or plain 
> va.h (or other_kind_hwaccel_api.h) in the future.
> e.g. for VA API, va.h is currently not installed under a specific va/ 
> directory. So, a #include "va.h" would be ambiguous.

Yes!  Now we can have a code-gem like this:

#include <va.h>
#include "va.h"

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list