[FFmpeg-devel] RTP mark bit not passed to parse_packet

Michael Niedermayer michaelni
Thu Jan 15 17:41:19 CET 2009

On Thu, Jan 15, 2009 at 04:04:00PM +0100, Alexandre FERRIEUX - FT/RD/SIRP/ASF/SOFTL wrote:
> Hi Michael,
> Michael Niedermayer wrote:
> > 
> > no, if AVSTREAM_PARSE_FULL is set a AVParser will be used to pack and
> > split things.
> Yes, I had forgotten that, sorry again :)
> > You can simply test this, just write the bitstream by simply concatenation
> > into a file with fwrite() ...
> > if it cannot be played back without similar errors then most likely it is
> > not a valid h263 stream and you forgot something (like to fix up the first
> > or last few bits that IIRC H263 RTP shuffles around)
> I did that, and the saved stream is played perfectly by mplayer.

does ffplay/ffmpeg play the stream?

> However, I'm still struggling to understand why the command:
> ./ffmpeg -dump -hex -debug pict -i /tmp/video/h263.sdp -vcodec copy out.263
> doesn't even create "out.263" nor prints any of the hex dumps...

a few printf()/av_log() should tell you where it gets stuck an why


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

The misfortune of the wise is better than the prosperity of the fool.
-- Epicurus
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20090115/4c504490/attachment.pgp>

More information about the ffmpeg-devel mailing list