[FFmpeg-devel] [PATCH] Clean up ipv6 vs the udp protocol

Luca Abeni lucabe72
Tue Jan 12 12:20:28 CET 2010

Martin Storsj? wrote:
> On Tue, 12 Jan 2010, Luca Abeni wrote:
>> Well, I think if there is no sockaddr_in6 there is no IPv6 too.
>> So, CONFIG_IPV6 seems to be a better name than CONFIG_IPV6_MULTICAST.
>> (the point being: sockaddr_in6 is related to IPv6, not to IPv6
>> multicast).
>> Or maybe the best thing would be to have HAVE_SOCKADDR_IN6,
>> instead of a CONFIG_* thing.
>> Based on this, I think your third patch should just check for the
>> presence of sockaddr_in6, instead of checking for IN6_IS_ADDR_MULTICAST...
>> No?
> We need struct ipv6_mreq also,

Yes, but the part of code I was commenting does not require ipv6_mreq.
So, I believe that particular "#if" can be removed (and the part requiring
ipv6_mreq can remain under "CONFIG_IPV6_MULTICAST").

> But yes, we could switch to checking for individual types, instead. Then 
> we'd have to check for both "struct ipv6_mreq" and "struct sockaddr_in6" 
> (unless you assume ipv6_mreq implies sockaddr_in6). Do you prefer that?

Yes, I believe this (checking for individual data types, and switching
from "CONFIG_*" to "HAVE_*") would be the best solution.


More information about the ffmpeg-devel mailing list