[FFmpeg-devel] [PATCH] avio: avio_ prefixes for get_* functions
Ronald S. Bultje
Sun Feb 20 20:00:44 CET 2011
On Feb 20, 2011, at 1:55 PM, "Ronald S. Bultje" <rsbultje at gmail.com> wrote:
> Hi Anton,
> On Feb 20, 2011, at 1:33 PM, Anton Khirnov <anton at khirnov.net> wrote:
>> In the name of consistency:
>> get_byte -> avio_r8
>> get_<type> -> avio_r<type>
>> get_buffer -> avio_read
>> get_partial_buffer -> avio_read_partial
> Can we remove the 'e' in [wr][bl]e<num>()? I can sed that, no need for a new patch.
And what is read_partial()? Does it have to be public API?
More information about the ffmpeg-devel