[FFmpeg-devel] [PATCH] Cope with VA-API 0.32

Ivan Kalvachev ikalvachev at gmail.com
Tue Mar 29 21:35:41 CEST 2011

On 3/29/11, Gwenole Beauchesne <gbeauchesne at splitted-desktop.com> wrote:
> Hi,
> On Mon, 28 Mar 2011, Michael Niedermayer wrote:
>> you are the vaapi expert, you know better than me if this is correct
>> and would break older versions or not. i think you dont need to send
>> patches for such changes
> Applied. If someone wants to support older (many months) code, I have code
> that adds support for any VA-API version back to 0.29, but that'd be come
> messy.
> Regards,
> Gwenole.

People are already complaining from broken builds.
How much messier is the code? It should be just one ifdef more.

You should either make it run for all versions (it run before)
or check for minimal version in configure.

More information about the ffmpeg-devel mailing list