[FFmpeg-devel] [PATCH] Cope with VA-API 0.32

Gwenole Beauchesne gbeauchesne at splitted-desktop.com
Wed Mar 30 06:37:21 CEST 2011


Le 30 mars 2011 à 04:34, Baptiste Coudurier a écrit :

> On 3/29/11 1:55 AM, Gwenole Beauchesne wrote:
>> Hi,
>> On Mon, 28 Mar 2011, Michael Niedermayer wrote:
>>> you are the vaapi expert, you know better than me if this is correct
>>> and would break older versions or not. i think you dont need to send
>>> patches for such changes
>> Applied. If someone wants to support older (many months) code, I have
>> code that adds support for any VA-API version back to 0.29, but that'd
>> be come messy.
> Can you check for the version in configure ? It seems compilation breaks
> for some users.

Here is what I suggest, in a 3 patch-set:
1) Add a version check for VA-API >= 0.32 and die ;
2) Add support for older API through #if check in vaapi_h264.c and change the die into a warn in configure ;
3) Move the VA-API check down around the VDPAU one.



More information about the ffmpeg-devel mailing list