[FFmpeg-devel] [patch] Fix a warning in fft_mmx.asm on mac

Nico Weber thakis at chromium.org
Tue Apr 17 01:58:22 CEST 2012

Hi again,

The attached patch is a revised version of my patch that also contains
a configure check that makes sure a recent enough yasm is used. See
the patch description for details. I checked that yasm 0.7.99 fails
this configure check, while passes it.

If you don't think this revised patch can be landed, please let me
know what's missing.


On Sun, Mar 11, 2012 at 7:15 PM, Nico Weber <thakis at chromium.org> wrote:
> Hi,
> the attached patch fixes a warning in fft_mmx.asm by deleting an old
> yasm / nasm bug workaround that should no longer be necessary.
> I tried adding a configure check if yasmexe has the bug, but I
> couldn't reproduce the problem this works around with yasm
> and ld64-127.2.
> (I tried to run `make fate`, but current trunk fails tests without any
> patches for me.)
> Nico
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Remove-.rodata-alignment-kludge-for-Mach-O.patch
Type: application/octet-stream
Size: 3048 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120416/0257db2e/attachment.obj>

More information about the ffmpeg-devel mailing list