[FFmpeg-devel] [PATCH] lavd/lavfi: do not set the channel layout list.

Clément Bœsch ubitux at gmail.com
Thu Jun 21 20:28:05 CEST 2012

On Thu, Jun 21, 2012 at 07:52:44PM +0200, Nicolas George wrote:
> Le quartidi 4 messidor, an CCXX, Stefano Sabatini a écrit :
> > Patch should be fine, but I can't see how this is related to #1474,
> > since the reporter is not even using the lavfi device.
> That is true. The story is that I used -f lavfi to get a similar problem (a
> file with the "FL" channel layout), fixed the bug, and forgot to check
> further. Now I can not reproduce ticket #1474.
> Pushed without the reference to the ticket.
> > [On a different ground, I don't like the NONE=ALL assumption because
> > it can lead to subtle bugs, an empty list is semantically different
> > from a "complete" list, in case I use some automated way to create a
> > list, with this assumption I need to check for the special case, which
> > wouldn't be required with a proper representation.]
> Unless I am mistaken, an empty list is never acceptable, so you need to
> check for the special case at one place or another anyway.
> I find this convention rather well designed, in fact.

I support this as well, the less to do for the filters the better (IMO).

Clément B.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120621/d354720c/attachment.asc>

More information about the ffmpeg-devel mailing list