[FFmpeg-devel] [PATCH] ffprobe: Add a few common disposition cases
derek.buitenhuis at gmail.com
Tue Sep 18 20:04:17 CEST 2012
On 18/09/2012 1:53 PM, Reimar Döffinger wrote:
>> The top two apply to audio and video streams, and the latter can only apply
>> to video streams. It is incorrect to test all three at the same location.
> So that leaves two cases
> 1) it is only ever set for video streams. Then nothing changes by checking them all in on place except that the code is clearer, more obvious and can be extracted into a separate function.
I do not think it should be a separate function, and I do not think it makes it clearer than having it
under the media type where it belongs.
I respectfully disagree.
> 2) somehow attached_picture gets set for an non-video steam. Why would ffprobe not printing it be a good thing?
If it gets set for anything but a video stream, then it is wrong, and a bug. "Attached Pic" on anything
but video is hilariously stupid.
>> What would you prefer as a name instead if is_attached_pic?
> Well, maybe just drop the is_? While I could possibly think of nicer names, I guess what we print should match the define name, so that leaves not much choice...
> But I don't care much, if you disagree just leave it.
Dropped the is_ locally.
More information about the ffmpeg-devel