[FFmpeg-devel] [PATCH] ffprobe: Add a few common disposition cases
Reimar.Doeffinger at gmx.de
Tue Sep 18 19:53:18 CEST 2012
On 18 Sep 2012, at 18:31, Derek Buitenhuis <derek.buitenhuis at gmail.com> wrote:
> On 18/09/2012 12:28 PM, Reimar Döffinger wrote:
>> That seems inconsistent to me, both that it is tested at a different
>> location and that it uses a is_* prefix.
> The top two apply to audio and video streams, and the latter can only apply
> to video streams. It is incorrect to test all three at the same location.
So that leaves two cases
1) it is only ever set for video streams. Then nothing changes by checking them all in on place except that the code is clearer, more obvious and can be extracted into a separate function.
2) somehow attached_picture gets set for an non-video steam. Why would ffprobe not printing it be a good thing?
> What would you prefer as a name instead if is_attached_pic?
Well, maybe just drop the is_? While I could possibly think of nicer names, I guess what we print should match the define name, so that leaves not much choice...
But I don't care much, if you disagree just leave it.
More information about the ffmpeg-devel