[FFmpeg-devel] VP8 decode on ARM

Michael Niedermayer michaelni at gmx.at
Wed Sep 19 13:01:11 CEST 2012

On Wed, Sep 19, 2012 at 08:29:29AM +0200, Andy Bell wrote:
> Hi All,
> I am decoding a VP8 stream on ARM.  The stream decodes OK but it sometime
> has artefacts in the decoded stream and it has a sort of blue/purple filter
> applied to the decoded frame.  The decoder is compiled with NEON
> optimisations, if I disable the ARM optimisations then the
> issue disappears so I can deduce that the issue has something to do with
> the ARM code.  I have, as far as I am aware, removed the NEON optimisation
> calls in the code by simply commenting out the assignments in
> vp8dsp_init_neon.c in the function ff_vp8dsp_init_neon but this makes no
> difference.  Does this suggest that the problem is elsewhere in the code
> and not in the ARM code?  How can I diagnose where the problem is?

compare config.h between ARM optims vs no ARM optims cases and
then grep for the changed #defines in the code and disable them
one by one or via binary search until you found which causes the
problem, once its known which causes the problem that code has to be


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

I do not agree with what you have to say, but I'll defend to the death your
right to say it. -- Voltaire
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120919/85347c84/attachment.asc>

More information about the ffmpeg-devel mailing list