[FFmpeg-user] Install FFMPEG with prefix (in CentOS) pls read!

Carl Eugen Hoyos cehoyos at ag.or.at
Mon Feb 27 10:17:55 CET 2012

Patryk Moura <patryk.moura <at> gmail.com> writes:

> Hey guys, im tryin to install ffmpeg in my CentOS, ive install all
> libraries with disabled-shared and prefix=/home/vamolaco/
> My problem is, ffmpeg keeps installing libs at /usr/lib... ive tried to
> change the --libdir=/home/vamolaco/lib, shlibdir.... ive tried
> enable-static,

./configure --prefix is supposed to work, please report if it does not.

> but ffmpeg again installed libasound.so.2 (link) in /usr/lib

FFmpeg does not install libasound.so.2
(It installs libavcodec, libavformat, libavutil and similar)

Are you searching for --extra-cflags=-I/home/vamolaco/include 
and --extra-ldflags=-L/home/vamolaco/lib ?

> and the libasound.so in the same dir (/usr/lib)... i want to install
> everything under the prefix ive setted...
> Can you guys help me, pls?

> This is a way for me, to install ffmpeg in my webhost that doesnt offer
> support for ffmpeg and don´t allow ssh access =(

If all you need is ffmpeg (the transcoding executable), just 
copy it wherever you need, it is not necessary to install.

Carl Eugen

More information about the ffmpeg-user mailing list