[FFmpeg-user] Problem building with OpenCV support

Misha Penkov misha.penkov at gmail.com
Thu Jun 28 08:50:10 CEST 2012

On 28 June 2012 15:44, Misha Penkov <misha.penkov at gmail.com> wrote:
> On 28 June 2012 15:12, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:
>> --extra-ldflags=-Wl,--no-as-needed
> Still no effect :(  The same error occurs.
> Did you notice the part in my previous email about replacing
> "-Wl,--as-needed" with "-Wl --as-needed" in the gcc command line?
> That seems to work, but I don't know how to get configure to use a
> space instead of a comma.

I've just man gcc and realized that -Wl,flags sends flags to the
linker, so the comma should definitely be there.  I'm a bit closer to
resolving the issue:

gcc -Wl,--no-as-needed -Wl,--as-needed ... doesn't work

gcc -Wl,--as-needed -Wl,--no-as-needed ... works

The order of the flags seems to matter, with the last command
overriding the previous one.  How can I specify
"--extra-ldflags=-Wl,--no-as-needed" such that it gets put AFTER
"-Wl,--as-needed" in the gcc command line?


More information about the ffmpeg-user mailing list