FFmpeg
Loading...
Searching...
No Matches
rtpenc.h
Go to the documentation of this file.
1/*
2 * RTP muxer definitions
3 * Copyright (c) 2002 Fabrice Bellard
4 *
5 * This file is part of FFmpeg.
6 *
7 * FFmpeg is free software; you can redistribute it and/or
8 * modify it under the terms of the GNU Lesser General Public
9 * License as published by the Free Software Foundation; either
10 * version 2.1 of the License, or (at your option) any later version.
11 *
12 * FFmpeg is distributed in the hope that it will be useful,
13 * but WITHOUT ANY WARRANTY; without even the implied warranty of
14 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
15 * Lesser General Public License for more details.
16 *
17 * You should have received a copy of the GNU Lesser General Public
18 * License along with FFmpeg; if not, write to the Free Software
19 * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
20 */
21#ifndef AVFORMAT_RTPENC_H
22#define AVFORMAT_RTPENC_H
23
24#include "avformat.h"
25#include "rtp.h"
26
32 uint32_t ssrc;
33 const char *cname;
34 int seq;
35 uint16_t seq_high;
36 uint32_t timestamp;
38 uint32_t cur_timestamp;
41
42 /* rtcp sender statistics */
45 unsigned int packet_count;
46 unsigned int octet_count;
47 unsigned int last_octet_count;
49 /* buffer for output */
50 uint8_t *buf;
51 uint8_t *buf_ptr;
52
54
55 /**
56 * Number of bytes used for H.264 NAL length, if the MP4 syntax is used
57 * (1, 2 or 4)
58 */
61
62 int flags;
63
64 unsigned int frame_count;
65};
66
67typedef struct RTPMuxContext RTPMuxContext;
68
69#define FF_RTP_FLAG_MP4A_LATM 1
70#define FF_RTP_FLAG_RFC2190 2
71#define FF_RTP_FLAG_SKIP_RTCP 4
72#define FF_RTP_FLAG_H264_MODE0 8
73#define FF_RTP_FLAG_SEND_BYE 16
74
75#define FF_RTP_FLAG_OPTS(ctx, fieldname) \
76 { "rtpflags", "RTP muxer flags", offsetof(ctx, fieldname), AV_OPT_TYPE_FLAGS, {.i64 = 0}, INT_MIN, INT_MAX, AV_OPT_FLAG_ENCODING_PARAM, .unit = "rtpflags" }, \
77 { "latm", "Use MP4A-LATM packetization instead of MPEG4-GENERIC for AAC", 0, AV_OPT_TYPE_CONST, {.i64 = FF_RTP_FLAG_MP4A_LATM}, INT_MIN, INT_MAX, AV_OPT_FLAG_ENCODING_PARAM, .unit = "rtpflags" }, \
78 { "rfc2190", "Use RFC 2190 packetization instead of RFC 4629 for H.263", 0, AV_OPT_TYPE_CONST, {.i64 = FF_RTP_FLAG_RFC2190}, INT_MIN, INT_MAX, AV_OPT_FLAG_ENCODING_PARAM, .unit = "rtpflags" }, \
79 { "skip_rtcp", "Don't send RTCP sender reports", 0, AV_OPT_TYPE_CONST, {.i64 = FF_RTP_FLAG_SKIP_RTCP}, INT_MIN, INT_MAX, AV_OPT_FLAG_ENCODING_PARAM, .unit = "rtpflags" }, \
80 { "h264_mode0", "Use mode 0 for H.264 in RTP", 0, AV_OPT_TYPE_CONST, {.i64 = FF_RTP_FLAG_H264_MODE0}, INT_MIN, INT_MAX, AV_OPT_FLAG_ENCODING_PARAM, .unit = "rtpflags" }, \
81 { "send_bye", "Send RTCP BYE packets when finishing", 0, AV_OPT_TYPE_CONST, {.i64 = FF_RTP_FLAG_SEND_BYE}, INT_MIN, INT_MAX, AV_OPT_FLAG_ENCODING_PARAM, .unit = "rtpflags" } \
82
83void ff_rtp_send_data(AVFormatContext *s1, const uint8_t *buf1, int len, int m);
84
85void ff_rtp_send_h264_hevc(AVFormatContext *s1, const uint8_t *buf1, int size);
86void ff_rtp_send_h261(AVFormatContext *s1, const uint8_t *buf1, int size);
87void ff_rtp_send_h263(AVFormatContext *s1, const uint8_t *buf1, int size);
88void ff_rtp_send_h263_rfc2190(AVFormatContext *s1, const uint8_t *buf1, int size,
89 const uint8_t *mb_info, int mb_info_size);
90void ff_rtp_send_aac(AVFormatContext *s1, const uint8_t *buff, int size);
91void ff_rtp_send_latm(AVFormatContext *s1, const uint8_t *buff, int size);
92void ff_rtp_send_amr(AVFormatContext *s1, const uint8_t *buff, int size);
93void ff_rtp_send_mpegvideo(AVFormatContext *s1, const uint8_t *buf1, int size);
94void ff_rtp_send_xiph(AVFormatContext *s1, const uint8_t *buff, int size);
95void ff_rtp_send_vc2hq(AVFormatContext *s1, const uint8_t *buf, int size, int interlaced);
96void ff_rtp_send_vp8(AVFormatContext *s1, const uint8_t *buff, int size);
97void ff_rtp_send_vp9(AVFormatContext *s1, const uint8_t *buff, int size);
98void ff_rtp_send_av1(AVFormatContext *s1, const uint8_t *buf1, int size, int is_keyframe);
99void ff_rtp_send_jpeg(AVFormatContext *s1, const uint8_t *buff, int size);
100void ff_rtp_send_raw_rfc4175(AVFormatContext *s1, const uint8_t *buf, int size, int interlaced, int field);
101
102const uint8_t *ff_h263_find_resync_marker_reverse(const uint8_t *restrict start,
103 const uint8_t *restrict end);
104
105#endif /* AVFORMAT_RTPENC_H */
Main libavformat public API header.
long long int64_t
Definition coverity.c:34
static int is_keyframe(NalUnitType naltype)
Definition libx265.c:94
uint8_t interlaced
Definition mxfenc.c:2336
void ff_rtp_send_h263_rfc2190(AVFormatContext *s1, const uint8_t *buf1, int size, const uint8_t *mb_info, int mb_info_size)
void ff_rtp_send_h264_hevc(AVFormatContext *s1, const uint8_t *buf1, int size)
void ff_rtp_send_vp9(AVFormatContext *s1, const uint8_t *buff, int size)
Definition rtpenc_vp9.c:26
void ff_rtp_send_vp8(AVFormatContext *s1, const uint8_t *buff, int size)
Definition rtpenc_vp8.c:26
void ff_rtp_send_h263(AVFormatContext *s1, const uint8_t *buf1, int size)
Packetize H.263 frames into RTP packets according to RFC 4629.
Definition rtpenc_h263.c:43
void ff_rtp_send_raw_rfc4175(AVFormatContext *s1, const uint8_t *buf, int size, int interlaced, int field)
void ff_rtp_send_jpeg(AVFormatContext *s1, const uint8_t *buff, int size)
Definition rtpenc_jpeg.c:28
const uint8_t * ff_h263_find_resync_marker_reverse(const uint8_t *restrict start, const uint8_t *restrict end)
Definition rtpenc_h263.c:26
void ff_rtp_send_aac(AVFormatContext *s1, const uint8_t *buff, int size)
Definition rtpenc_aac.c:27
void ff_rtp_send_mpegvideo(AVFormatContext *s1, const uint8_t *buf1, int size)
Definition rtpenc_mpv.c:29
void ff_rtp_send_av1(AVFormatContext *s1, const uint8_t *buf1, int size, int is_keyframe)
Definition rtpenc_av1.c:42
void ff_rtp_send_data(AVFormatContext *s1, const uint8_t *buf1, int len, int m)
Definition rtpenc.c:370
void ff_rtp_send_amr(AVFormatContext *s1, const uint8_t *buff, int size)
Packetize AMR frames into RTP packets according to RFC 3267, in octet-aligned mode.
Definition rtpenc_amr.c:30
void ff_rtp_send_h261(AVFormatContext *s1, const uint8_t *buf1, int size)
Definition rtpenc_h261.c:39
void ff_rtp_send_xiph(AVFormatContext *s1, const uint8_t *buff, int size)
Packetize Xiph frames into RTP according to RFC 5215 (Vorbis) and the Theora RFC draft.
Definition rtpenc_xiph.c:33
void ff_rtp_send_vc2hq(AVFormatContext *s1, const uint8_t *buf, int size, int interlaced)
void ff_rtp_send_latm(AVFormatContext *s1, const uint8_t *buff, int size)
Definition rtpenc_latm.c:25
Describe the class of an AVClass context structure.
Definition log.h:76
Format I/O context.
Definition avformat.h:1400
Stream structure.
Definition avformat.h:768
uint16_t seq_high
Definition rtpenc.h:35
int buffered_nals
Definition rtpenc.h:60
int num_frames
Definition rtpenc.h:40
int nal_length_size
Number of bytes used for H.264 NAL length, if the MP4 syntax is used (1, 2 or 4)
Definition rtpenc.h:59
uint8_t * buf_ptr
Definition rtpenc.h:51
AVStream * st
Definition rtpenc.h:30
int max_frames_per_packet
Definition rtpenc.h:53
unsigned int packet_count
Definition rtpenc.h:45
const char * cname
Definition rtpenc.h:33
uint32_t cur_timestamp
Definition rtpenc.h:38
uint32_t ssrc
Definition rtpenc.h:32
int64_t first_rtcp_ntp_time
Definition rtpenc.h:44
int payload_type
Definition rtpenc.h:31
uint32_t base_timestamp
Definition rtpenc.h:37
const AVClass * av_class
Definition rtpenc.h:28
int max_payload_size
Definition rtpenc.h:39
uint32_t timestamp
Definition rtpenc.h:36
unsigned int frame_count
Definition rtpenc.h:64
int64_t last_rtcp_ntp_time
Definition rtpenc.h:43
uint8_t * buf
Definition rtpenc.h:50
unsigned int last_octet_count
Definition rtpenc.h:47
int first_packet
Definition rtpenc.h:48
unsigned int octet_count
Definition rtpenc.h:46
AVFormatContext * ic
Definition rtpenc.h:29
int size
int len