[Ffmpeg-cvslog] r5918 - in trunk/libavcodec/ppc: dsputil_altivec.c dsputil_altivec.h dsputil_ppc.c
Luca Barbato
lu_zero
Fri Aug 4 03:23:51 CEST 2006
Michael Niedermayer wrote:
> Hi
>
> [...]
>> @@ -1712,10 +1712,10 @@
>> t0 = vec_cmple(m, (vector float)vec_splat_u32(0));
>> t1 = vec_cmple(a, (vector float)vec_splat_u32(0));
>> a = vec_xor(a, (vector float) vec_sl((vector unsigned int)t0, v_31));
>> - s0 = vec_and(a, t1);
>> - s1 = vec_andc(a, t1);
>> - a = vec_add(m, s0);
>> - m = vec_sub(m, s1);
>> + t0 = (vector bool int)vec_and(a, t1);
>> + t1 = (vector bool int)vec_andc(a, t1);
>> + a = vec_add(m, (vector float)t0);
>> + m = vec_sub(m, (vector float)t1);
>
> unrelated change?
> btw, the first 2 casts look redundant, are they really needed?
The cast are needed, got mixed up with the rest (damn I should use git
when I work with multiple patch on the same file...)
>
> [...]
>> @@ -256,62 +259,32 @@
>> {
>> // Common optimizations whether Altivec is available or not
>>
>> - switch (check_dcbzl_effect()) {
>> - case 32:
>> - c->clear_blocks = clear_blocks_dcbz32_ppc;
>> - break;
>> - case 128:
>> - c->clear_blocks = clear_blocks_dcbz128_ppc;
>> - break;
>> - default:
>> - break;
>> - }
>> + switch (check_dcbzl_effect()) {
>> + case 32:
>> + c->clear_blocks = clear_blocks_dcbz32_ppc;
>> + break;
>> + case 128:
>> + c->clear_blocks = clear_blocks_dcbz128_ppc;
>> + break;
>> + default:
>> + break;
>> + }
>>
>> #ifdef HAVE_ALTIVEC
>> - dsputil_h264_init_ppc(c, avctx);
>> + dsputil_h264_init_ppc(c, avctx);
>
> [...]
>> - if (avctx->lowres==0)
>> - {
>> + if (avctx->lowres==0)
>> + {
>> if ((avctx->idct_algo == FF_IDCT_AUTO) ||
>> (avctx->idct_algo == FF_IDCT_ALTIVEC))
>> {
>> c->idct_put = idct_put_altivec;
>> c->idct_add = idct_add_altivec;
>> -#ifndef ALTIVEC_USE_REFERENCE_C_CODE
>> + #ifndef ALTIVEC_USE_REFERENCE_C_CODE
>> c->idct_permutation_type = FF_TRANSPOSE_IDCT_PERM;
>> -#else /* ALTIVEC_USE_REFERENCE_C_CODE */
>> + #else /* ALTIVEC_USE_REFERENCE_C_CODE */
>> c->idct_permutation_type = FF_NO_IDCT_PERM;
>> -#endif /* ALTIVEC_USE_REFERENCE_C_CODE */
>> + #endif /* ALTIVEC_USE_REFERENCE_C_CODE */
>> + }
>> }
>> - }
>
> that too should be in a seperate commit
I could rename the commit to "Cosmetics all around the file" so it will
be quite descriptive of it as whole ^^;
(the change from variables to cast is spurious, the 2->4 spaces and the
reorder was on purpose since I consider both cosmetic)
>
> sadly svn doesnt provide a way to reverse this? :(((((((
I can revert the files to the previous status with up -r
previous_revision and then ci again.
> so i suggest you to send a patch next time you want to violate
> svn policy or find a way to reverse it before doing it ...
Sorry for the mixup, I'll try to be more careful next time.
lu
--
Luca Barbato
Gentoo/linux Gentoo/PPC
http://dev.gentoo.org/~lu_zero
More information about the ffmpeg-cvslog
mailing list