[FFmpeg-devel] [PATCH] lavu/threadmessage: add av_thread_message_queue_nelem()
u at pkh.me
Sun Apr 22 19:32:40 EEST 2018
On Sun, Apr 22, 2018 at 12:33:14PM +0200, Marton Balint wrote:
> On Sun, 22 Apr 2018, Clément Bœsch wrote:
> > On Sun, Apr 22, 2018 at 02:51:16AM +0100, Rostislav Pehlivanov wrote:
> > [...]
> > > I think av_thread_message_queue_elems would be a better name, had to think
> > > for a good period of time what "nelem" meant.
> > I'm afraid of "queue_elems" implying "queuing elements" so I went for
> > the more explicit av_thread_message_queue_nb_elems() instead.
> I generally prefer nb_items instead of nb_elems. Use whichever you like.
No personal opinion on this but the "element" semantic is already in use
in the API so I'd rather follow that.
More information about the ffmpeg-devel