[FFmpeg-user] Problem trying to convert PAL file to NTSC

vsethi at iglou.com vsethi at iglou.com
Sat Mar 19 13:44:16 CET 2011

Etienne Buira wrote:

> On Fri, Mar 18, 2011 at 07:25:17PM -0400, I wrote:
>> I have built ffmpeg 6.1 and it produces the same result (same error messages).
>> Since I am unfamiliar with the ffmpeg package overall, all I can think of
>> are the following possibilities:
>> 1.  ffmpeg is missing (although not complaining about missing) some file
>>     that it needs.  (A library perhaps?)
>> 2.  there is a duplication of file names in the filesystem that is causing 
>>     ffmpeg to consult the wrong file.
> You can make sure using which ffmpeg and ldd /path/to/ffmpeg

Until I added 6.1, there was only one ffmpeg on the system.  I did check
the dependent libraries:  they're all Slackware 12.0 files, about which
neither ffmpeg nor its configure script is complaining.

>> 3.  ffmpeg just cannot process my file.
>> 4.  ???
>> Short of going into the source code and trying to figure out what ffmpeg 
>> is trying to do and guessing why it cannot do it, I don't know what
>> else to try.  (Well, I guess there's the debugger.)
> Is that different if you try ffmpeg -f mpeg -i inputfile.mpg ?
> (You can try some other formats instead of mpeg, depending which you see
> relevant, from the list given by ffmpeg -formats | grep -i mpeg | grep'^ D').

I looked at the list of formats for decoding, but I don't know which 
corresponds to what mplayer says about the file:

  MPEG-PS file format detected
  VIDEO MPEG2 720 x 576 (aspect 2) 25.000 fps 8648.0 kbps (1081.0 kbyte/s)
  Opening video decoder:  [mpegpes]
  Opening video decoder:  [ffmpeg]  FFmpeg's libavcodec codec family
  Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)

Thanks for your help.

More information about the ffmpeg-user mailing list