[FFmpeg-user] Problem trying to convert PAL file to NTSC

Etienne Buira etienne.buira.lists at free.fr
Sat Mar 19 14:26:38 CET 2011

On Sat, Mar 19, 2011 at 08:44:16AM -0400, vsethi at iglou.com wrote:
> Etienne Buira wrote:
> > On Fri, Mar 18, 2011 at 07:25:17PM -0400, I wrote:
> >
> >> I have built ffmpeg 6.1 and it produces the same result (same error messages).
> >> Since I am unfamiliar with the ffmpeg package overall, all I can think of
> >> are the following possibilities:
> >> 
> >> 1.  ffmpeg is missing (although not complaining about missing) some file
> >>     that it needs.  (A library perhaps?)
> >> 2.  there is a duplication of file names in the filesystem that is causing 
> >>     ffmpeg to consult the wrong file.
> >
> > You can make sure using which ffmpeg and ldd /path/to/ffmpeg
> Until I added 6.1, there was only one ffmpeg on the system.  I did check
> the dependent libraries:  they're all Slackware 12.0 files, about which
> neither ffmpeg nor its configure script is complaining.

Do you mean that ffmpeg binary you built is loading package manager
installed libav{device,filter,format,codec,core,util} ?
If so, I suggest you to have a close look at what files are from what,
eventually uninstalling all versions of ffmpeg and looking at configure
options (builds statically by default on last git version, don't know
about 0.6.1).

> >> 3.  ffmpeg just cannot process my file.
> >> 4.  ???
> >> 
> >> Short of going into the source code and trying to figure out what ffmpeg 
> >> is trying to do and guessing why it cannot do it, I don't know what
> >> else to try.  (Well, I guess there's the debugger.)
> >
> > Is that different if you try ffmpeg -f mpeg -i inputfile.mpg ?
> > (You can try some other formats instead of mpeg, depending which you see
> > relevant, from the list given by ffmpeg -formats | grep -i mpeg | grep'^ D').
> I looked at the list of formats for decoding, but I don't know which 
> corresponds to what mplayer says about the file:
>   MPEG-PS file format detected

That is the container format, so that should be handled by the 'mpeg'
demuxer (thus, try the suggested line).

More information about the ffmpeg-user mailing list