[FFmpeg-user] -threads option has no effect

Rohit Talwar rohittalwar04 at gmail.com
Tue Aug 12 11:59:38 CEST 2014


I ran the command - ffmpeg -threads <number of threads> -i <my file.avi>
<target.mp4> hoping it would not hog my cpu and consume only one core of my
machine. But it was still taking up all of my cpu. I ran the following
experiments to confirm my suspicion that including the -threads option has
no effect on cpu usage.

1. One instance of ffmpeg with -threads 1 -- results in full cpu usage

2. One instance of ffmpeg with -threads 2 -- results in full cpu usage
(similar was the case with -threads 3 and 4)

3. 2 Instances of ffmpeg one with -threads as 2 and the other with -threads
1 -- result both instances used same amount of cpu ~45-48%

4. 3 Instances of ffmpeg all with -threads 1 -- result is the same equal
cpu usage summing to ~95% of cpu

-threads option as advertised here [0] does not seem to work in that way.
I launch ffmpeg from inside a java program and am trying to limit its cpu
consumption, can anyone point me in the right direction on how to achieve

Thanks !!



Rohit Talwar

More information about the ffmpeg-user mailing list