[FFmpeg-user] -threads option has no effect

James Darnley james.darnley at gmail.com
Tue Aug 12 12:09:14 CEST 2014

On 2014-08-12 11:59, Rohit Talwar wrote:
> Hi
> I ran the command - ffmpeg -threads <number of threads> -i <my file.avi>

Perhaps you should not be using it as an input option.

> <target.mp4> hoping it would not hog my cpu and consume only one core of my
> machine. But it was still taking up all of my cpu. I ran the following
> experiments to confirm my suspicion that including the -threads option has
> no effect on cpu usage.

Why do you not want it to use as much CPU as it can?  If this is a
desktop that you are using at the same time you should lower the
priority of the ffmpeg process.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 618 bytes
Desc: OpenPGP digital signature
URL: <https://ffmpeg.org/pipermail/ffmpeg-user/attachments/20140812/2e2d446d/attachment.asc>

More information about the ffmpeg-user mailing list