[FFmpeg-user] -threads option has no effect

Rohit Talwar rohittalwar04 at gmail.com
Tue Aug 12 12:56:39 CEST 2014


Thanks for looking into my query. I have a main java program within which I
run ffmpeg (using exec). Often there comes a scenario wherein my program
needs to create 4+ different instances of ffmpeg program for converting
files into different formats. When this happens the cpu gets 'too busy'
running the ffmpeg instances which affects the performance of my java
I think lowering the priority(using nice or start /LOW )  of the ffmpeg
process might be a possible strategy to solve this, but would be glad if
you can help me point towards a platform independent solution.

On Tue, Aug 12, 2014 at 3:39 PM, James Darnley <james.darnley at gmail.com>

> On 2014-08-12 11:59, Rohit Talwar wrote:
> > Hi
> >
> > I ran the command - ffmpeg -threads <number of threads> -i <my file.avi>
> Perhaps you should not be using it as an input option.
> > <target.mp4> hoping it would not hog my cpu and consume only one core of
> my
> > machine. But it was still taking up all of my cpu. I ran the following
> > experiments to confirm my suspicion that including the -threads option
> has
> > no effect on cpu usage.
> Why do you not want it to use as much CPU as it can?  If this is a
> desktop that you are using at the same time you should lower the
> priority of the ffmpeg process.
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user


Rohit Talwar

More information about the ffmpeg-user mailing list