[FFmpeg-user] Problem with a YT video

jd1008 jd1008 at gmail.com
Thu Apr 28 18:46:41 CEST 2016

Hi Mortz,
I tried the following:
$ ffmpeg -i Into_Great_Darkness.mp4 -vf 
"crop=w=iw/2:h=ih:x=0:y=0,scale=w=2*iw:h=ih,setdar=dar=1.777" -y 

It is still running, currently at frame=16591

But, when I try to play Into_Great_Darknes-2.mp4 (even if not finished 
I get only pixellation - no images.
The output of mplayer command is:

$ mplayer Into_Great_Darkness-2.mp4
MPlayer 1.2.1-5.3.1 (C) 2000-2016 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote 

Playing Into_Great_Darkness-2.mp4.
libavformat version 56.25.101 (external)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f6d93e6e6a0]moov atom not found
LAVF_header: av_open_input_stream() failed
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f6d93e6e6a0]moov atom not found
LAVF_header: av_open_input_stream() failed
RAWDV file format detected.
VIDEO:  [DVSD]  720x480  24bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in ./
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 56.26.100 (external)
Selected video codec: [ffdv] vfm: ffmpeg (FFmpeg DV)
Opening audio decoder: [libdv] Raw DV Audio Decoder
Unknown/missing audio format -> no sound
ADecoder init failed :(
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Cannot find codec 'dvaudio' in libavcodec...
ADecoder init failed :(
ADecoder init failed :(
Cannot find codec for audio format 0x56444152.
Audio: no sound
Starting playback...
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
Movie-Aspect is undefined - no prescaling applied.
[swscaler @ 0x7f6d940f7260]bicubic scaler, from yuv411p to yuv420p using 
VO: [xv] 720x480 => 720x480 Planar YV12
[dvvideo @ 0x7f6d9342cf20]AC EOB marker is absent pos=65

with the last line repeated for hundreds if not thousands of times at 
different positions.

On 04/24/2016 11:02 AM, Moritz Barsnick wrote:
> On Sun, Apr 24, 2016 at 10:46:50 -0600, jd1008 wrote:
>> OK, that plays one screen. Well and good !!!
>> I had to download it to get one viewing screen.
> How did your download manage to cut it in half? BTW, you can feed the
> stream URL directly to ffplay (your URL may vary):
> $ ffplay -i 'https://r6---sn-5hnedn7s.googlevideo.com/videoplayback?mime=video%2Fmp4&dur=9590.119&upn=jYWGghj_TK4&itag=22&ip=' -vf "crop=w=iw/2:h=ih:x=0:y=0,scale=w=2*iw:h=ih,setdar=2*dar"
>> BUT - No Audio :( :(
> Mine has. Perhaps your download tool downloaded the video-only stream.
> (Have you checked "youtube-dl -F"?)
>> PS: Even if you play it in the browser , it is 2 virtual screens.
> Not here. YouTube recognizes it as 3D and does some magic when playing
> (in Firefox). (Note, I think I am using YouTube without Flash. Not that
> it should matter.)
>> on my laptop using any one of the linux media players - but without the
>> dual viewing windows.
> What are those Linux YouTube players? smtube possibly?
> You're still not correctly writing what you're trying to achieve and
> what you're actually doing. Like really doing.
> Moritz
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list