[FFmpeg-user] HLS - command line hls_segment_size creates problems in segments

Phantom Scripts phantomscripts at hotmail.com
Fri Apr 5 02:05:45 EEST 2019

I hope that here I can get some response, I tried several means to have some help.

I've been on this problem for several weeks.

first I'll leave a link to a page with a player for the HLS video with the problem:
in this video, just in the second 7, a locking occurs
this problem occurs in the transition from segment0.ts to segment1.ts

I used this command

ffmpeg.exe in.mp4 -vcodec copy -acodec aac -hls_list_size 0 -hls_segment_size 17000000 -f hls out.m3u8

I'm using ‘-hls_segment_size’ to have an ideal file size(17000000 =  ~17MB) for each segment and get byte-ranges in the m3u8 file

I researched everything, and tried everything to not have this problem but it always happens the same thing.
I think this is a bug from ffmpeg...

What I'm trying to get is this:

  1.  get segments (.ts) with sizes close to 17MB (-hls_segment_size was the ideal command)
  2.  have an M3U8 file, with bytes ranges (using '-hls_segment_size' I also get byte-ranges)

I'm looking at a way to cut my file in ideial size, and somehow get byte ranges to every 7 ~ 10 seconds, and create a custom m3u8 file (I do not know how to do it)

More information about the ffmpeg-user mailing list