[FFmpeg-user] HLS - command line hls_segment_size creates problems in segments

Carl Eugen Hoyos ceffmpeg at gmail.com
Fri Apr 5 03:56:48 EEST 2019

2019-04-05 1:05 GMT+02:00, Phantom Scripts <phantomscripts at hotmail.com>:

> I hope that here I can get some response, I tried several
> means to have some help.

Just curious:
What did you try?

> I've been on this problem for several weeks.
> first I'll leave a link to a page with a player for the HLS video with the
> problem:
> http://phantsc.rf.gd/AAA/Bbb.html
> in this video, just in the second 7, a locking occurs
> this problem occurs in the transition from segment0.ts to segment1.ts
> I used this command
> ffmpeg.exe in.mp4 -vcodec copy -acodec aac -hls_list_size 0
> -hls_segment_size 17000000 -f hls out.m3u8

Complete, uncut console output missing.

> I'm using ‘-hls_segment_size’ to have an ideal file size(17000000 =  ~17MB)
> for each segment and get byte-ranges in the m3u8 file

And what does not work?

> I researched everything, and tried everything to not have this problem but
> it always happens the same thing.
> I think this is a bug from ffmpeg...
> What I'm trying to get is this:
>   1.  get segments (.ts) with sizes close to 17MB (-hls_segment_size was the
> ideal command)
>   2.  have an M3U8 file, with bytes ranges (using '-hls_segment_size' I also
> get byte-ranges)
> I'm looking at a way to cut my file in ideial size, and somehow get byte
> ranges to every 7 ~ 10 seconds, and create a custom m3u8 file (I do not know
> how to do it)

Why do you use hls_segment_size if you want a time segment?

Carl Eugen

More information about the ffmpeg-user mailing list