[FFmpeg-user] RES: HLS - command line hls_segment_size creates problems in segments

Phantom Scripts phantomscripts at hotmail.com
Fri Apr 5 04:28:35 EEST 2019

thanks for answering Carl Eugen, but I think you do not understand.

I'm trying to create segments with a defined file size, for example 17MB, and have byte ranges in the m3u8 file

this command:

ffmpeg.exe -i in.mp4 -vcodec copy -accodec aac -hls_list_size 0 -hls_segment_size 17000000 -f hls out.m3u8

in the console works, creates the .TS Files, and the .m3u8 file.

the m3u8 file contains byte ranges.

but there is a problem during the vídeo.

in this link:


contains an hls player, which contains the files I created with the mentioned command,

touch play in the video and look at the second 7, for some milleseconds the video and audio 'hangs'

this happens in the whole video, when it is from a segment to a new segment.

I need to use '-hls_segment_size' to set a maximum size of segment files

and use '-hls_time' to set the seconds for byte-ranges in the m3u8 file.

touch play on the video of the link, you will see the problem(pay attention to audio and video)

De: ffmpeg-user <ffmpeg-user-bounces at ffmpeg.org> em nome de Carl Eugen Hoyos <ceffmpeg at gmail.com>
Enviado: Thursday, April 4, 2019 9:56:48 PM
Para: FFmpeg user questions
Assunto: Re: [FFmpeg-user] HLS - command line hls_segment_size creates problems in segments

2019-04-05 1:05 GMT+02:00, Phantom Scripts <phantomscripts at hotmail.com>:

> I hope that here I can get some response, I tried several
> means to have some help.

Just curious:
What did you try?

> I've been on this problem for several weeks.
> first I'll leave a link to a page with a player for the HLS video with the
> problem:
> http://phantsc.rf.gd/AAA/Bbb.html
> in this video, just in the second 7, a locking occurs
> this problem occurs in the transition from segment0.ts to segment1.ts
> I used this command
> ffmpeg.exe in.mp4 -vcodec copy -acodec aac -hls_list_size 0
> -hls_segment_size 17000000 -f hls out.m3u8

Complete, uncut console output missing.

> I'm using ‘-hls_segment_size’ to have an ideal file size(17000000 =  ~17MB)
> for each segment and get byte-ranges in the m3u8 file

And what does not work?

> I researched everything, and tried everything to not have this problem but
> it always happens the same thing.
> I think this is a bug from ffmpeg...
> What I'm trying to get is this:
>   1.  get segments (.ts) with sizes close to 17MB (-hls_segment_size was the
> ideal command)
>   2.  have an M3U8 file, with bytes ranges (using '-hls_segment_size' I also
> get byte-ranges)
> I'm looking at a way to cut my file in ideial size, and somehow get byte
> ranges to every 7 ~ 10 seconds, and create a custom m3u8 file (I do not know
> how to do it)

Why do you use hls_segment_size if you want a time segment?

Carl Eugen
ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org

To unsubscribe, visit link above, or email
ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list