[FFmpeg-user] ffplay struggling with this station!

Mark Filipak (ffmpeg) markfilipak at bog.us
Thu Sep 24 08:01:08 EEST 2020

On 09/24/2020 12:52 AM, Edward Park wrote:
> Hi,
> I just realized that the station was public, so I just tried:
> % ffplay -nodisp -vn "https://jrtv-live.ercdn.net/jrradio/englishradiovideo.m3u8”
> no issues.
>> I did try without that buffer flag, but that had no effect. I’m going to try updating ffplay, and see if that helps.
> Yeah also update the tls library before building and if that still doesn’t fix it it might be the connection speed?
>> Also, I’ve noticed that vlc had a 1000 ms “network cache”, and I wonder if that had anything to do with playing that station flawlessly.
> That probably means something like it’s’ playing 1 second in the past, so if something happens and it can’t keep up in realtime there’s still 1 second to fix it before it skips.

That's exactly what it means, though I think the word "buffer" would be more appropriate.

cache [noun]: a temporary storage space or memory that allows fast access to data.

buffer [noun]: a storage device for temporarily holding data until the computer is ready to receive 
or process the data, as when a receiving unit has an operating speed lower than that of the unit 
feeding data to it.

More information about the ffmpeg-user mailing list