[FFmpeg-user] ffplay struggling with this station!

Firas Shahin f1ras at yahoo.com
Thu Sep 24 16:29:35 EEST 2020

Well, I just tried that command you suggested, but it still skipped whenever it fetched a new TS. And it couldn’t be my connection speed as I have more than a Gbps internet speed. But this tells me that it must be the software versions, since you didn’t have any issues. I’ll update the software and let you guys know. Thank you for your help. 

> On Sep 24, 2020, at 00:04, Mark Filipak (ffmpeg) <markfilipak at bog.us> wrote:
> On 09/24/2020 12:52 AM, Edward Park wrote:
>> Hi,
>> I just realized that the station was public, so I just tried:
>> % ffplay -nodisp -vn "https://jrtv-live.ercdn.net/jrradio/englishradiovideo.m3u8”
>> no issues.
>>> I did try without that buffer flag, but that had no effect. I’m going to try updating ffplay, and see if that helps.
>> Yeah also update the tls library before building and if that still doesn’t fix it it might be the connection speed?
>>> Also, I’ve noticed that vlc had a 1000 ms “network cache”, and I wonder if that had anything to do with playing that station flawlessly.
>> That probably means something like it’s’ playing 1 second in the past, so if something happens and it can’t keep up in realtime there’s still 1 second to fix it before it skips.
> That's exactly what it means, though I think the word "buffer" would be more appropriate.
> cache [noun]: a temporary storage space or memory that allows fast access to data.
> buffer [noun]: a storage device for temporarily holding data until the computer is ready to receive or process the data, as when a receiving unit has an operating speed lower than that of the unit feeding data to it.
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
> To unsubscribe, visit link above, or email
> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list