[FFmpeg-user] m3u8 download has no audio track

Moritz Barsnick barsnick at gmx.net
Tue Nov 8 09:09:13 EET 2022

Hi Carl,

On Mon, Nov 07, 2022 at 21:01:38 -0500, Carl Fink wrote:
> ffmpeg -i"http://example.com/video_url.m3u8"  -c copy -bsf:a aac_adtstoasc "output.mp4"
> This has worked in the past, but lately from Nebula, I get an output
> file with no audio track, according to ffplay, and also vlc and mplayer.

If you show us the complete output of the original command, we could
see that the stream probably doesn't contain the audio at all.

How do you obtain the stream URL?

> Suggestions? What information can I post that will help to debug this.

Have you tried using yt-dlp for downloading your content? It is usually
aware of separate stream URLs for video and audio, if that is the case.

> Note: I am a paying Nebula subscriber and do not pirate their content.
> I just want to be able to watch it offline, notably on planes.

I have absolutely no problem with that. :)


More information about the ffmpeg-user mailing list