[Libav-user] unable to play live webm chunks generated using ffmpeg webm_dash_manifest muxer and webm_chunk muxer

ravikiran.bs ravikiran.bs at zohocorp.com
Thu Jun 7 15:22:28 EEST 2018


I tried using Google's shaka player, instead of dash-if player to play the webm live chunks generated using ffmpeg muxers. It didn't work for the case where both audio and video streams were present. Then I tried audio only and video only cases. Interestingly, it is working fine for audio only scenario. 

But in video only scenario, I am able to generate a few video chunks and then segmentation fault occurs always somewhere inside  mkv_write_flush_packet() of matroskaenc.c. It is not consistently occuring for same memory object, but always happening inside mkv_write_flush_packet() which is called from webm_chunk muxer's webm_chunk_write_packet() method. 

I have tried with a keyframe interval of 15secs and 5secs. In both cases, same thing is happening - i.e first few video chunks are generated and then application crashes because of some segmentation fault inside write_packet(). Any help regarding this will be much helpful. Thanks.


Ravi Kiran B S

---- On Wed, 06 Jun 2018 18:53:22 +0530 Carl Eugen Hoyos <ceffmpeg at gmail.com> wrote ----

2018-06-06 9:01 GMT+02:00, ravikiran.bs <ravikiran.bs at zohocorp.com>:

> I generate .hdr and .chk files of the actual stream using webm_chunk muxer.

> I am using both the muxers programmatically, not from the command line.

Can you reproduce the issue you see if create the files using the ffmpeg

application from the command line?

Carl Eugen


Libav-user mailing list

Libav-user at ffmpeg.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20180607/11f4c81b/attachment.html>

More information about the Libav-user mailing list