[FFmpeg-devel] MMX accelerated DSP functions for VC1/WMV3 decoders

Uoti Urpala uoti.urpala
Sun Jul 1 18:23:32 CEST 2007

On Sun, 2007-07-01 at 16:50 +0200, Christophe GISQUET wrote:
> here's a new version, where the license header now specifies strictly
> v2.0 of the _Library_ General Public License, which is probably the most
> I would accept. Its text is not directly available anymore from the
> Licenses pages of the fsf and gnu sites.

As Herv? W. already pointed out, this license version also allows
conversion to any version of the GPL. And this idea would have no chance
of working anyway: if the earlier version of the license did have
different requirements then specifying "the earlier version and no
later" would be incompatible with the rest of FFmpeg which specifies
"2.1 or later".

> The question whether I accept version 2.1 or 3.0 of the LGPL or GPL is
> moot, as you pointed their texts offer a kind of loophole to select
> another version, which I disagree with.

LGPL allows conversion to any version of the GPL, but the GPL does not.
Neither GPL 2 nor GPL 3 allows conversion to a later version as an
integral part of the license itself. The right to use under "version X
of the License, or (at your option) any later version" is given (or not)

More information about the ffmpeg-devel mailing list